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NOTICE TO USERS
Ontrack® PowerControls™ is a software application that has been developed, copyrighted,
and licensed by KLDiscovery Ontrack, LLC. Use of the software is governed by the terms and
conditions of the end user license agreement contained within the software.
This manual should not be construed as any representation or warranty with respect to the
software named herein. Occasionally, changes or variations exist in the software that are not
reflected in the manual.
Generally, if such changes or variations are known to exist and affect the product significantly, a
release note or Read Me file will accompany the User Guide, or will be available on the Ontrack
PowerControls website. In that event, please read the release notes or Read Me file before using
the product.

TRADEMARKS
Ontrack, PowerControls, and other Ontrack brand and product names referred to herein are
trademarks or registered trademarks of KLDiscovery Ontrack, LLC, and/or its parent company, or
used under license from their respective owners in the United States and/or other countries. All
other brand and product names are trademarks of their respective owners.
Microsoft, Exchange, SharePoint, SQL, Windows and other Microsoft brand and product names
referred to herein are either registered trademarks or trademarks of Microsoft Corporation in the
United States and/or other countries.
All other brand and product names are trademarks of their respective owners.

COPYRIGHTS AND THIRD PARTY SOFTWARE NOTICES
Copyright © 2020 KLDiscovery Ontrack, LLC. All rights reserved.
DVN: 9.3.2.0.1
No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval
system, or translated into a language or computer language, in any form by any means,
electronic, mechanical, optical, chemical, manual or otherwise, without the express written
consent of KLDiscovery Ontrack, LLC.

Boost Software License - Version 1.0 - August 17th, 2003
Permission is hereby granted, free of charge, to any person or organization obtaining a copy of
the software and accompanying documentation covered by this license (the "Software") to use,
reproduce, display, distribute, execute, and transmit the Software, and to prepare derivative
works of the Software, and to permit third-parties to whom the Software is furnished to do so, all
subject to the following:
The copyright notices in the Software and this entire statement, including the above license
grant, this restriction and the following disclaimer, must be included in all copies of the Software,
in whole or in part, and all derivative works of the Software, unless such copies or derivative works
are solely in the form of machine-executable object code generated by a source language
processor.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE COPYRIGHT
HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER
LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

CONTACT INFORMATION
For contact information for our worldwide locations, see
http://www.ontrack.com
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Overview
Welcome to Ontrack® PowerControls™, the granular recovery software that saves time, money,
and resources when restoring Microsoft® SQL Server data.
With Ontrack PowerControls, you can:
n

Restore tables from native SQL BAK files or offline MDF and LDF in seconds or minutes
without restoring the entire database

n

Preview table contents before restoring table

n

Restore from backup or storage tier snapshot directly

Ontrack PowerControls supports SQL 2005 and later and can read MDF, LDF, NDF, and BAK files
from a variety of data sources, such as a local or shared drive, an external hard drive or even a
storage tier snapshot from a SAN environment.

About the Free Trial
After installation, Ontrack PowerControls operates as a Free Trial by default until a license file is
applied. The Free Trial of Ontrack PowerControls is limited in functionality and time-limited to 30
days of use.
With the Free Trial, you can:
n

Open sources

n

Open targets

If you would like to have full functionality, or learn more about the purchasing options and
product information for Ontrack PowerControls, visit our website at http://www.ontrack.com.

Data Security
The Ontrack PowerControls user requires:
n

Read access to any SQL 2005 and later offline database files or backup files to be opened
as a source.

n

Administrator access to any SQL Server where the data is to be restored.
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Chapter 1: Looking at the Interface
The Ontrack PowerControls main window is divided into the two Source panes (Source Tree View
and Source List) above the two Target panes (Target Tree View and Target List).

Key items:
1. Menu Bar
2. Toolbar
3. Source Location
4. Source Tree View
5. Source List
6. Source List Status Bar
7. Target Location
8. Target Tree View
9. Target List
10. Target List Status Bar
11. Main Window Status Bar
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Source and Target Panes
The Source panes display the contents of the source MDF, NDF, and LDF files, or the first full
backup in the source BAK file. The Source Tree View displays the selected source database in a
hierarchical view. The Source List displays the columns of the tables selected in the Source Tree
View.
Note: Unsupported columns also appear, but the data in the cells may appear as
<UNSUPPORTED>
The Target panes act as a container for the restored objects on the target server. The Target
Tree View contains the Microsoft SQL Server tables that you copy, drag, or add through the
Data Wizard. The Target List pane displays the columns of the tables selected in the Target Tree
View.
When you select a table in either the Source or Target Tree View, the following appear in the
corresponding List:
n

Up to the first 1,024 columns (each column displays up to 300 characters).

n

Up to the first 1,000 rows.

Note: A notice appears in the corresponding List's status bar when the selected table exceeds
these amounts.
Any functions that can be performed on a source or target are available on the menu bar, the
toolbar, or the shortcut menus. For more information, see "Restoring Microsoft SQL Server Tables"
on page 6

Changing the Appearance of the Main Window
You can change the view in the Ontrack PowerControls window by:
n

Viewing or hiding the Toolbar and Status Bar

n

Resizing panes separated by a split bar

n

Resizing columns in the Source and Target Lists

n

Refreshing the screen

Viewing or Hiding the Toolbar and Status Bar
The toolbar and status bar appear by default in the main window, but you can easily hide them.
To hide or view the toolbar or status bar
n

On the View menu, select or clear Toolbar or Status Bar. A check mark indicates that the
bar is shown.

Resizing Panes Separated by a Split Bar
You can use a split bar (the horizontal or vertical double line that separates two panes) to
increase the area within one pane while simultaneously decreasing the area within the
adjacent pane.
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To resize panes separated by a split bar
1. Position the pointer over a split bar between the two panes on either the vertical or
horizontal split bar.

Figure 1-1: Resizing panes with the double-headed arrow
2. When the pointer becomes a double-headed arrow, drag it to resize the pane.

Resizing Columns in the Source and Target Lists
You can change the width of the columns in the Source and Target Lists.
To resize columns
1. Place the pointer between the columns in either the Source or Target Lists.
2. When the pointer becomes a double-headed arrow, drag it to resize the column width.
Note: You can double-click the double-headed arrow to automatically adjust the
column width.

Refreshing the Screen
You may want to refresh the screen occasionally when you are connected to a live target
server, as the information on the server may update.
To refresh the screen
n

Do one of the following:
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l

On the View menu, select Refresh.

l

Press the F5 key.

Setting Preferences
Use Preferences to set defaults for recurrent operations, such as running the Data Wizard when
you start the application.
To change preference settings
1. On the Edit menu, select Preferences.
2. Select or clear the following check boxes, as needed:
n

Run Data Wizard on startup: If selected, the Data Wizard starts every time you open
Ontrack PowerControls.

n

Show warning when no log files specified: If selected, a warning message appears
when opening a file if an LDF file path has not been specified.

n

Show referential integrity warning: If selected, a warning message appears when
copying tables with foreign keys.

3. In the Temporary File Path box, accept the default location for the .IDX and .DAT files or, if
the files require more hard drive space, specify a new location by clicking Browse (...).
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Chapter 2: Restoring Microsoft SQL
Server Tables
You can restore a Microsoft SQL Server table by doing the following:
A. Select the source MDF, LDF, and NDF file paths or the source BAK file path.
Important: Verify that the log files and database files were created in the same backup. If your
source database contains an NDF file, it must be included with the MDF file.
1. Open the Source Path Selection page of the SQL Data Wizard by doing one of the
following:
n

On the toolbar, click Open Source

.

n

On the File menu, select Open Source.

n

Press Ctrl+S.

n

Drag the files to open onto the Source Tree view of the main window.

2. In the Source Type drop-down list, select either Files or Folder.
n

If you selected Files, do one of the following:
l

l

Click Add and use the Open dialog box to browse for the source MDF file, NDF
files, LDF files, or BAK files.
Open Windows Explorer and drag the source files from their location onto the
Source Files box.

Note: Multiple files can be added to the Source Files box and are listed in the order
they were added; however, only a single database can be opened. Please select
either Microsoft SQL Database files (*.MDF , *.NDF , *.LDF) or Microsoft SQL backup
files, not a combination of both. If you want to remove files from the Source Files
box, select the file and click Remove.
n

If you selected Folder, do one of the following:
l

Enter the location of the SQL data folder.

l

Select the path of a previously selected folder.

l

l

Open Windows Explorer and drag the source folder from its location onto the
Source Folder drop-down list
Click Browse and use the Browse For Folder dialog box to locate the Microsoft
SQL source folder.

3. Click Finish.
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Note: When opening Transparent Data Encryption databases, after clicking Finish an "Add
Transparent Data Encryption Database requirements" window appears. Add a path to
Transparent Data Encryption database key and provide Transparent Data Encryption key
password.
B. Connect to the Microsoft SQL Server you are using as the target for your restored data.
1. Open the Target Server Path Selection page of the SQL Data Wizard by doing one of the
following:
n

On the toolbar, click Open Target

n

On the File menu, select Open Target.

n

Press Ctrl+T.

.

2. In the SQL Server Name list, do one of the following:
n

Enter the name of the Microsoft SQL Server you are using as the target.

n

Use the drop-down arrow to select a previously used target.

n

If you do not know exact name of the Microsoft SQL Server, click the drop-down
arrow, then select <Browse for more…>. On the Browse for Servers dialog box,
choose a target scope of either Local Servers or Network Servers, then select the
SQL Server instance you want to connect to and click OK.
Note: Similar to Microsoft SQL Server Management Studio, the number of instances
listed in the Network Servers tab can vary between queries, for example, when
network load prevents server response. Also, the following are not displayed:

n

l

Hidden instances

l

Servers not running SQL Server Browser service

l

Servers with blocked UDP port (1434)

(Optional) To specify a port number (if selected instance is installed on a port other
than default 1433), type the server name, followed by a comma and the port
number (value from 1 to 65535).
Example: server_name\instance_name,1234.

3. In the Authentication group, select one of the following:
n

Use Windows Authentication to use Windows credentials of the currently logged-in
user to access the web service.

n

Use SQL Server Authentication to use Microsoft SQL credentials, then enter the
Username and Password of the user.

4. In the Database group, do one of the following:
n

Select Connect to Single Database and enter the database you are using as the
target or use the drop-down arrow to select a database on the SQL Server you are
using as the target.

n

Select Connect to Server to connect to the SQL Server you are using as the target
and view all its available databases in the Target Tree View pane.

5. Click Finish.
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C. Copy and paste (or drag) a table from a SQL database backup (source) into a live SQL
database (target)

To copy a table from the Source Tree View
1. In the Source Tree View, select the table to copy.
2. Do one of the following:
n

Click the Copy icon

on the toolbar.

n

On the Edit menu, select Copy.

n

Press Ctrl+C (copy).

To paste a table to the Target Tree View
1. In the Target Tree View, select a Tables node.
2. Do one of the following:
n

Click the Paste icon

on the toolbar.

n

On the Edit menu, click Paste.

n

Press Ctrl+V (paste).

To drag a table to the Target Tree View
n

Drag a table from the Source Tree View into a Tables node in the Target Tree View.
Dragging achieves the same results as copying and pasting.

Using the Data Wizard
The Ontrack PowerControls DataWizard guides you through Steps A and B of "Restoring
Microsoft SQL Server Tables" on page 6.
To open the Data Wizard
n

On the File menu, click Use Wizard.

Opening the Source Database from the Command Line
In addition to using the Data Wizard, you can open the source databases with the command
line.
To open the source database with the command line
1. Open a command prompt window.
2. Type the location of the Ontrack PowerControls installation files, followed by PC.SQL.exe.
Enclose both together within double quotes.
3. Append this with the source file(s) and the temporary file path (optional) as parameters.
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n

Each source file name must be prefixed with the keyword -sourcefile and enclosed
within double quotes. The prefix and the file name must be separated with a space.

n

Each source folder name must be prefixed with the keyword -sourcefolder and
enclosed within double quotes. The prefix and the folder name must be separated
with a space.

n

The temporary file path must be prefixed with -t keyword and enclosed within
double quotes. The prefix and the temporary file path name must:
n Be separated with a space
n

Not end with a backslash.

Note: To automatically open the specified source database and view it in the source tree
view, type -o.
4. Press Enter.
n

If the "Show wizard on startup" box is cleared on the Data Wizard, Ontrack
PowerControls opens the Data Wizard at the Source Path Selection page with the
command line content displayed.

Sample Command Lines
Sample Command

Result

"C:\[application location]\PC.SQL.exe" -sourcefile
"U:\SQL
Database\BAK\2008R2\AdventureWorks2008R2.bak"

Opens the Data Wizard with the source file
AdventureWorks2008R2.bak pre-populated.

"C:\[application location]\PC.SQL.exe" -sourcefile
"U:\SQL
Database\BAK\2008R2\AdventureWorks2008R2.bak" t "C:\Users\administrator\AppData\Local\Temp\PC"

Opens the Data Wizard with the source file
AdventureWorks2008R2.bak and temporary path
C:\Users\administrator\AppData\Local\Temp\PC
pre-populated.

"C:\[application location]\PC.SQL.exe" -sourcefolder
"U:\SQL Database\BAK\2008R2" -t
"C:\Users\administrator\AppData\Local\T emp\PC" –o

Opens the 2008R2 source folder and
automatically displays it in the source tree view.

"C:\[application location]\PC.SQL.exe" -sourcefile
Opens the source AdventureWorks2008R2 from
"U:\SQL Database\2008 R2 \AdventureWorks2008R2_ MDF and LDF and automatically displays it in the
Data.mdf" -sourcefile "U:\SQL Database\2008
source tree view.
R2\AdventureWorks2008R2_log.LDF" -o
"C:\[application location]\PC.SQL.exe -sourcefile
"U:\SQLBACKUPS\Stripe1.bak" -sourcefile
"U:\SQLBACKUPS\Stripe2.bak" -sourcefile
"U:\SQLBACKUPS\Stripe3.bak” –o

Opens multiple backup files that belong to the
same backup set.

Viewing Copy Progress
Each time you attempt to restore objects to the Target Tree View, Copy Progress displays the
following information:
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n

Source, Source Path, Target, and Target Path

n

Time of the start of the copy operation

n

Number of tables to be processed

n

Warnings and errors, if any

n

Number of rows processed

n

Time the copy operation completed

To print Copy Progress Data as a report
n

Click Print for a report of the Copy Progress information.

To save Copy Progress Data as a report
n

Click Save for a text file of the Copy Progress report.
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Chapter 3: Troubleshooting
If you have issues not addressed in the user guide or the online Help, call our Technical Support
group (1-952-937-2121). When reporting an issue, please include any information that might help
us diagnose the problem and have the following:
n

The version of Ontrack PowerControls you are using (on the Help menu, click About)

n

The versions of Windows operating systems that you are running

n

The circumstances and sequence of steps that led to the problem

n

The text of the error messages (if any appeared).

n

A list of other Windows-based programs that you were running when the error occurred
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About KLDiscovery Ontrack
Ontrack provides technology-driven services and software
to help legal, corporate and government entities as well as
consumers manage, recover, search, analyze, and produce
data efﬁciently and cost-effectively. In addition to its awardwinning suite of software, Ontrack provides data recovery,
data destruction, electronic discovery and document review.
For more information about Ontrack and its offerings please
visit: www.ontrack.com.

CONTACT
For more information, call or visit us online:
800.645.3649 or +1.952.937.5161
www.ontrack.com
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